Going from Fedora to Rocky on my personal laptop. If this ends up being not too painful, I'll probably go with RHEL for my work laptop in a while.

What with using Flatpak for all my desktop applications, having a base OS with a slower release cycle seems quite viable.

@returntrip no, I still have it on my work laptop, but in my new work role I work with non-Podman container stuff most of the time.

Things are still possible to work around, but it is starting to feel a bit pointless to use it when I have to layer external repos, and hundreds of packages (when dependencies are counted).

@bkhl understandable.... for the machine I use at work there is one thing in I have not been able to fix and that nags me: Cisco Anyconnect VPN client cannot be layered/installed...sometimes I also think about switching to standard Fedora for work...

@returntrip what I used to do with janky customer VPNs was to run the client in a VM (Windows if that was easier), then route through it.

@bkhl I tried that, but for some reason my system (16GB RAM) was struggling to handle the VM NAD its standard workload (I think I have way too many browser tabs open)

@returntrip the main question for me is if the "old" will be a problem for me. Emacs in Flatpak was pretty quirky when I tried it, and even if it would work great it would be inconvenient as my workflows now depend on Emacs launching containers a lot (e.g. to run LSP servers and tests).

Fedora Workstation is an option of course, but feels silly for _one_ program (even if it is Emacs).

@bkhl I missed the original post, so I'm guessing at the original issue. But what about (a) just building Emacs from source? or (b) using Nix's/Guix's Emacs on top of whatever distro you're using?

@returntrip

@emacsomancer @returntrip yup, if that's the only application that's an issue with using a longer term release distro I might just compile my own Emacs.

@bkhl I compile my own anyway since I'm using Emacs 28.0.5. It's not a major burden.
@returntrip

@emacsomancer @returntrip yeah, wouldn't think so. I guess I will do it the minute I find something lacking in Emacs 26, which is what RHEL is currently on. It's not _that_ old, so maybe I won't even notice the difference ...

@bkhl depends mainly on what packages you use probably. there could be something targeting 27. but 26 is only a couple of years old.

@returntrip

Follow

@emacsomancer @returntrip the main thing is the JSON parsing performance improvements, since I use LSP a lot. I guess I'll find out soon if it's fast enough anyway.

· · Web · 0 · 0 · 1
Sign in to participate in the conversation
Mastodon @ SDF

"I appreciate SDF but it's a general-purpose server and the name doesn't make it obvious that it's about art." - Eugen Rochko